Friday, April 13, 2012

An Easy way to check UCM latest SDI log

RTMT is not bad, however it is still not as quick as you enter command via CLI.  You can use the following command to check the latest SDI log.

Example – it shows the latest 300 lines of SDI logs

file tail activelog cm/trace/ccm/sdi recent 300

Easy Virtual Network

Scenario: In this scenario there are 3 routers interconnected, with 3 VRFs namely Android, IOS and WP7 created.  VNET trunk is configured in order to reduce the complexity and administration effort in configuring the routers in between.

Reference:  http://www.cisco.com/en/US/docs/ios/ios_xe/evn/configuration/guide/evn_confg_xe.html#wp1060221

Topology

VRF android (eth1/0), iOS (eth1/1) and wp7 (eth1/2) -- R4 (eth1/3 vnet trunk) -- (eth1/3 vnet trunk) R5 (eth1/0 vnet trunk) -- (eth1/3 vnet trunk) R6 -- VRF android (eth1/0), iOS (eth1/1) and wp7 (eth1/2)  

Image(14)

R4 Config

Current configuration : 2285 bytes

!

! Last configuration change at 01:38:17 HKT Sat Mar 24 2012

!

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

!

hostname R4

!

boot-start-marker

boot-end-marker

!

!

vrf definition android

vnet tag 1001

!

address-family ipv4

exit-address-family

!

vrf definition ios

vnet tag 1002

!      

address-family ipv4

exit-address-family

!

vrf definition wp7

vnet tag 1003

!

address-family ipv4

exit-address-family

!

!

no aaa new-model

!

!

!

clock timezone HKT 8 0

ip cef

!

!

!

!

!

!

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

!

interface Ethernet0/1

no ip address

shutdown

!

interface Ethernet0/2

no ip address

shutdown

!

interface Ethernet0/3

no ip address

shutdown

!

interface Ethernet1/0

 vrf forwarding android

ip address 10.1.1.1 255.255.255.0

!

interface Ethernet1/1

 vrf forwarding ios

ip address 10.2.2.1 255.255.255.0

!

interface Ethernet1/2

 vrf forwarding wp7

ip address 10.3.3.1 255.255.255.0

!

interface Ethernet1/3

 vnet trunk

ip address 192.168.1.1 255.255.255.0

 ip ospf vnet area 0

vnet name android

  ip ospf 2 area 0

!

vnet name ios

  ip ospf 3 area 0

!

vnet name wp7

  ip ospf 4 area 0

!

!

interface Serial2/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/3

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/3

no ip address

shutdown

serial restart-delay 0

!

router ospf 2 vrf android

router-id 1.1.1.2

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 3 vrf ios

router-id 1.1.1.3

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 4 vrf wp7

router-id 1.1.1.4

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 1

router-id 1.1.1.1

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

!

!

no ip http server

!

!

!

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

R5 Config

Building configuration...

Current configuration : 2290 bytes

!

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

!

hostname R5

!

boot-start-marker

boot-end-marker

!

!

vrf definition android

vnet tag 1001

!

address-family ipv4

exit-address-family

!

vrf definition ios

vnet tag 1002

!

address-family ipv4

exit-address-family

!

vrf definition wp7

vnet tag 1003

!

address-family ipv4

exit-address-family

!

!

no aaa new-model

!

!

!

clock timezone HKT 8 0

ip cef

!

!

!

!

!

!

no ipv6 cef

!

!        

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

!

interface Ethernet0/1

no ip address

shutdown

!

interface Ethernet0/2

no ip address

shutdown

!

interface Ethernet0/3

no ip address

shutdown

!

interface Ethernet1/0

 vnet trunk

ip address 192.168.2.1 255.255.255.0

ip ospf vnet area 0

vnet name android

  ip ospf 2 area 0

!

vnet name ios

  ip ospf 3 area 0

!

vnet name wp7

  ip ospf 4 area 0

!

!

interface Ethernet1/1

no ip address

shutdown

!

interface Ethernet1/2

no ip address

shutdown

!

interface Ethernet1/3

vnet trunk

ip address 192.168.1.2 255.255.255.0

 ip ospf vnet area 0

vnet name android

  ip ospf 2 area 0

!

vnet name ios

  ip ospf 3 area 0

!

vnet name wp7

  ip ospf 4 area 0

!

!

interface Serial2/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/3

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/3

no ip address

shutdown

serial restart-delay 0

!

router ospf 2 vrf android

router-id 2.2.2.2

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 3 vrf ios

router-id 2.2.2.3

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 4 vrf wp7

router-id 2.2.2.4

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 1

router-id 2.2.2.1

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

!

!

no ip http server

!

!

!

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login   

!

!

end

R6 Config

Building configuration...

Current configuration : 2285 bytes

!

! Last configuration change at 01:39:03 HKT Sat Mar 24 2012

!

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

!

hostname R6

!

boot-start-marker

boot-end-marker

!

!

vrf definition android

vnet tag 1001

!

address-family ipv4

exit-address-family

!

vrf definition ios

vnet tag 1002

!      

address-family ipv4

exit-address-family

!

vrf definition wp7

vnet tag 1003

!

address-family ipv4

exit-address-family

!

!

no aaa new-model

!

!

!

clock timezone HKT 8 0

ip cef

!

!

!

!

!

!

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

!

interface Ethernet0/1

no ip address

shutdown

!

interface Ethernet0/2

no ip address

shutdown

!

interface Ethernet0/3

no ip address

shutdown

!

interface Ethernet1/0

vrf forwarding android

ip address 10.4.4.1 255.255.255.0

!

interface Ethernet1/1

 vrf forwarding ios

ip address 10.5.5.1 255.255.255.0

!

interface Ethernet1/2

 vrf forwarding wp7

ip address 10.6.6.1 255.255.255.0

!

interface Ethernet1/3

 vnet trunk

ip address 192.168.2.2 255.255.255.0

ip ospf vnet area 0

vnet name android

  ip ospf 2 area 0

!

vnet name ios

  ip ospf 3 area 0

!

vnet name wp7

  ip ospf 4 area 0

!

!

interface Serial2/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial2/3

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial3/3

no ip address

shutdown

serial restart-delay 0

!

router ospf 2 vrf android

router-id 3.3.3.2

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 3 vrf ios

router-id 3.3.3.3

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 4 vrf wp7

router-id 3.3.3.4

network 0.0.0.0 255.255.255.255 area 0

!

router ospf 1

router-id 3.3.3.1

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

!

!

no ip http server

!

!

!

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

Show command

R5#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1           1   FULL/DR         00:00:33    192.168.1.1     Ethernet1/3

3.3.3.1           1   FULL/BDR        00:00:37    192.168.2.2     Ethernet1/0

1.1.1.4           1   FULL/DR         00:00:36    192.168.1.1     Ethernet1/3.1003

3.3.3.4           1   FULL/BDR        00:00:31    192.168.2.2     Ethernet1/0.1003

1.1.1.3           1   FULL/DR         00:00:38    192.168.1.1     Ethernet1/3.1002

3.3.3.3           1   FULL/BDR        00:00:31    192.168.2.2     Ethernet1/0.1002

1.1.1.2           1   FULL/DR         00:00:32    192.168.1.1     Ethernet1/3.1001

3.3.3.2           1   FULL/BDR        00:00:30    192.168.2.2     Ethernet1/0.1001

R5#sh ip int brie

Interface              IP-Address      OK? Method Status                Protocol

Ethernet0/0            unassigned      YES NVRAM  administratively down down   

Ethernet0/1            unassigned      YES NVRAM  administratively down down   

Ethernet0/2            unassigned      YES NVRAM  administratively down down   

Ethernet0/3            unassigned      YES NVRAM  administratively down down   

Ethernet1/0            192.168.2.1     YES NVRAM  up                    up     

Ethernet1/0.1001       192.168.2.1     YES NVRAM  up                    up    

Ethernet1/0.1002       192.168.2.1     YES NVRAM  up                    up    

Ethernet1/0.1003       192.168.2.1     YES NVRAM  up                    up    

Ethernet1/1            unassigned      YES NVRAM  administratively down down   

Ethernet1/2            unassigned      YES NVRAM  administratively down down   

Ethernet1/3            192.168.1.2     YES NVRAM  up                    up     

Ethernet1/3.1001       192.168.1.2     YES NVRAM  up                    up    

Ethernet1/3.1002       192.168.1.2     YES NVRAM  up                    up    

Ethernet1/3.1003       192.168.1.2     YES NVRAM  up                    up     

Serial2/0              unassigned      YES NVRAM  administratively down down   

Serial2/1              unassigned      YES NVRAM  administratively down down   

Serial2/2              unassigned      YES NVRAM  administratively down down   

Serial2/3              unassigned      YES NVRAM  administratively down down   

Serial3/0              unassigned      YES NVRAM  administratively down down   

Serial3/1              unassigned      YES NVRAM  administratively down down   

Serial3/2              unassigned      YES NVRAM  administratively down down   

Serial3/3              unassigned      YES NVRAM  administratively down down    

R5#sh ip route vrf android

Routing Table: android

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 2 subnets

O        10.1.1.0 [110/20] via 192.168.1.1, 00:08:53, Ethernet1/3.1001

O        10.4.4.0 [110/20] via 192.168.2.2, 00:08:24, Ethernet1/0.1001

      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.1.0/24 is directly connected, Ethernet1/3.1001

L        192.168.1.2/32 is directly connected, Ethernet1/3.1001

      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.2.0/24 is directly connected, Ethernet1/0.1001

L        192.168.2.1/32 is directly connected, Ethernet1/0.1001

R5#show derived-config int eth1/3.1001

Building configuration...

Derived configuration : 183 bytes

!

interface Ethernet1/3.1001

description Subinterface for VNET android

encapsulation dot1Q 1001

vrf forwarding android

ip address 192.168.1.2 255.255.255.0

ip ospf 2 area 0

end

Service Advertisement Framework (SAF) Testing

Scenario:  In this test lab setup, there are 2 CM clusters and 1 CME and they are using SAF to advertise and learn their dial plan.  Both CM clusters are sharing the same SAF Forwarder, on the other hand CME are co-host with the SAF Forwarder using the same ISRG2 router.

The IOS version is 15.2, and it is a bit different from the configuration in the past.  The “external label” is removed from the EIGRP service family configuration, the new XMCP service routing is introduced.  The SAF Forwarder is the XMCP server and the UCM is the XMCP client.

Topology:

Image(1)

SAF Forwarder Configuration (for both UCM clusters)

SAF1#sh run

Building configuration...
Current configuration : 1958 bytes
!
! Last configuration change at 19:18:45 HKT Fri Mar 23 2012
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SAF1
!
boot-start-marker
boot-end-marker
!
!
enable password cisco
!
no aaa new-model
clock timezone HKT 8 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
username cisco
!
!
!
!
!
!
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
ip address dhcp
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
ip address 10.20.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
!
router eigrp SAFTEST
!
service-family ipv4 autonomous-system 1
  !
  topology base
  exit-sf-topology
exit-service-family
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
no ip http server
!
service-routing xmcp listen ipv4
client username safuser password 0 safpassword
  domain 1 default
!
!
!
!
!
mgcp profile default
!
!
!
!
voice service saf
!
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end

Show command

SAF1#  show service-routing xmcp server
XMCP Server listening on port 4788
  Socket descriptors: 0 (TCP/IPv4)
  Connected clients: 0 unauthenticated, 2 total
  Maximum clients: unlimited
  Allow-lists: <none>
  Clients configured:
    Username "safuser", 2 client(s) connected

SAF1#  show service-routing xmcp client
Service-Routing XMCP Clients
Codes: A - Authenticated, T - TCP
    Handle     Address                                    Port  Keepalive
AT  3          192.168.90.223                            34220    22/30
    Client name: UCM/CM_cm86/NodeId=1/8.6.1.20000-1
AT  4          192.168.90.201                            60342    16/30
    Client name: UCM/192.168.90.201/NodeId=1/8.5.1.10000-26

SAF1#  show service-routing database
Service-Routing Database
Service ID (Service:Subservice:Instance)         Trust     Domain Owner Size
------------------------------------------------ --------- ------ ----- -----
      100:1:31000000-0000-0000-0000-000000000000 Connected *      1       319
      100:2:31000000-0000-0000-0000-000000000000 Connected *      1      1086
      101:2:275952D8-C2F9-38A8-AE06-8CE5000160D1 Connected 1      3       665
      101:2:733EF17C-84BD-5610-0325-D23200019F2E Connected 1      4       676

UCM Configuration

SAF Security Profile

Image(2)

SAF Forwarder (Client Label = username in new XCMP configuration)

Image(3)

Hosted DN Group

Image(4)

Hosted DN Pattern

Image(5)

Advertising Service

Image(6)

CCD Partition

Image(7)

Requesting Service

Image(8)

SAF Trunk

Image(9)

RTMT – The learnt dial plan is shown in RTMT

Image(10)

Then let’s move on to see the CME + SAF Forwarder configuration

CME + SAF Forwarder + SAF Client config

Current configuration : 2508 bytes
!
! Last configuration change at 20:42:48 HKT Fri Mar 23 2012
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SAF2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone HKT 8 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.20.30.1 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
ip address 10.20.1.2 255.255.255.252
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
!
router eigrp SAFTEST
!
service-family ipv4 autonomous-system 1
  !
  topology base
  exit-sf-topology
exit-service-family
!

router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!

ip forward-protocol nd
!
no ip http server
!
!
!
!
!

!
dial-peer voice 1000 voip
destination-pattern ^1...$
session target saf
!
dial-peer voice 2000 voip
destination-pattern ^2...$
session target saf
!
mgcp profile default
!
!
!
!
voice service saf
profile trunk-route 1
  session protocol h323 interface Loopback0 transport tcp port 1720
  session protocol sip interface Loopback0 transport udp port 5060
!
profile dn-block 1
  pattern 1 type extension 3xxx
!
profile callcontrol 1
  dn-service name test
   trunk-route 1
   dn-block 1
  !
!
call
  timer aar-ageout 15
  pattern prefix
  !
!
channel 1 vrouter SAFTEST asystem 1
  subscribe callcontrol wildcarded
  publish callcontrol 1
!
!
!
telephony-service
max-ephones 30
max-dn 30
ip source-address 10.20.30.1 port 2000
max-conferences 4 gain -6
transfer-system full-consult
!
!
ephone-dn  1
number 3001
!
!
ephone  1
mac-address AABB.CCDD.EEFF
type 7965
button  1:1
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
!
end

RTMT – See the learnt DNs from CME

Image(12)

Gatekeeper + CME 9.0 + 8945 + EX90 (TC 4.2) Testing

Scenario:  Wants to have CME IP phones talked to standalone EX90.  In this test lab, 2 x 8945 phones are registered to CME 9.0 as a SCCP video end point.  The CME, gateway, and gatekeeper are co-host in the same physical ISR G2 router.  EX90 is registered to the gatekeeper directly as a H.323 terminal. 

End result: 8945 calling EX90, 2 way video works.  The negotiated resolution is 352x288, therefore on EX90 it doesn’t look great, however at least they can connect and make call to each other.  Tried PVDM3 on ISRG2 as the video switching bridge, however it doesn’t work at all, one-way video is resulted. 

Image

Reference:  http://www.cisco.com/en/US/tech/tk1077/technologies_configuration_example09186a00807ca099.shtml

Configuration

cme-video#sh run

Building configuration...

Current configuration : 5424 bytes

!

! Last configuration change at 18:58:41 HKT Tue Mar 20 2012

! NVRAM config last updated at 18:53:32 HKT Tue Mar 20 2012

! NVRAM config last updated at 18:53:32 HKT Tue Mar 20 2012

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cme-video

!

boot-start-marker

boot system flash:c2900-universalk9-mz.SPA.152-2.T1.bin

boot-end-marker

!

!

!

no aaa new-model

!

clock timezone HKT 8 0

!

no ipv6 cef

ip auth-proxy max-login-attempts 5

ip admission max-login-attempts 5

!

!

!

ip dhcp excluded-address 192.168.100.1 192.168.100.100

!

ip dhcp pool phone-pool

network 192.168.100.0 255.255.255.0

default-router 192.168.100.1

option 150 ip 192.168.100.1

!

ip dhcp pool PC

network 192.168.200.0 255.255.255.0

default-router 192.168.200.1

!

!

no ip domain lookup

ip domain name ccievoice.com

ip cef

!

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

!

voice-card 0

voice-service dsp-reservation 0

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  registrar server expires max 1200 min 300

!

voice class h323 1

  call start slow                      ! slow start is required for video

!

!

voice register global

mode cme

source-address 192.168.100.1 port 5060

max-dn 20

max-pool 20

timezone 42

time-format 24

date-format D/M/Y

create profile sync 0002883849114141

!

voice register dn  1

number 1001

name Phone 2

label +85225881001

!

voice register dn  2

number 1002

name Phone 3

label +85225881002

!

voice register pool  1

id mac 04C5.A4B0.D13C

type 9951

number 1 dn 1

dtmf-relay sip-notify

description --Phone 2--

codec g711ulaw

camera

video

!

voice register pool  2

id mac 1C17.D341.8FD2

type 9971

number 1 dn 2

dtmf-relay sip-notify

description --Phone 3--

codec g711ulaw

camera

video

!

voice register pool  3

!

!

!

!

!

license udi pid CISCO2911/K9 sn FHK1444F2EK

license accept end user agreement

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

ip address 192.168.100.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip id GK ipaddr 192.168.100.1 1719

h323-gateway voip h323-id CME

!

interface GigabitEthernet0/0.200

encapsulation dot1Q 200

ip address 192.168.200.1 255.255.255.0

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

no ip address

!

interface GigabitEthernet0/0/1

no ip address

!

interface GigabitEthernet0/0/2

no ip address

!

interface GigabitEthernet0/0/3

no ip address

!

interface Vlan1

no ip address

!

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0.100

sccp ccm 192.168.100.1 identifier 1 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register CFB-VIDEO

!

dspfarm profile 1 conference video homogeneous

codec g711ulaw

codec h264 cif frame-rate 30 bitrate 320kbps               ! Meetme conference not working for EX90 (only send video, not receive video), only 2 x 8945 is working.  Tried ad-hoc, error message results and only audio remains.  Other resolution is worse.  Point to Point video between EX90 and 8945 is CIF quality

maximum sessions 1

associate application SCCP

!

dial-peer voice 1005 voip

destination-pattern 1005

video codec h264

session target ras

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

!

gateway

timer receive-rtp 1200

!

!

!

gatekeeper

zone local GK cisco.com

no shutdown

!

!

telephony-service

sdspfarm units 1

sdspfarm tag 1 CFB-VIDEO

no auto-reg-ephone

max-ephones 20

max-dn 20

ip source-address 192.168.100.1 port 2000

time-zone 42

time-format 24

date-format dd-mm-yy

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp 7960 Mar 20 2012 18:13:08

!

!

ephone-template  1

softkeys hold  Join Newcall Resume Select

softkeys idle  Cfwdall ConfList Dnd Join Newcall Pickup Redial RmLstC

softkeys seized  Endcall Redial Meetme Cfwdall Pickup

softkeys connected  ConfList Confrn Endcall Hold Trnsfer Join Park RmLstC Select

!

!

ephone-dn  1  octo-line

number 1000

!

!

ephone-dn  2  octo-line

number 1004

!

!

ephone-dn  10  octo-line

number 1111

description --Meet Me Conf--

conference meetme video homogeneous

!

!

ephone-dn  20  octo-line

number 1234

conference ad-hoc video

!

!

ephone  1

device-security-mode none

description +85225881000

video

mac-address 503D.E57D.89C8

ephone-template 1

type 8945

button  1:1

!

!

!

ephone  2

device-security-mode none

video

mac-address 503D.E57D.87F8

ephone-template 1

type 8945

button  1:2

!

!

!

ephone  3

device-security-mode none

!

!

!

ephone  20

device-security-mode none

!

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

exec-timeout 0 0

privilege level 15

logging synchronous

no login

transport input all

line vty 5 40

login

transport input all

!

scheduler allocate 20000 1000

ntp master

!

end

Enable Root Access for EX60 / 90

To enable EX60 / 90 linux kernel with root access, you can first access the unit using the admin user right from a SSH client:

[root@panda ~]# ssh -l admin 192.168.10.1
Welcome to
TANDBERG Codec Release TC5.0.1.275220
SW Release Date: 2011-12-19

OK

systemtool rootsettings get


off


OK


systemtool rootsettings on


OK

Then you can access the unit with root access:

[root@panda ~]# ssh -l root 192.168.10.1
[tandberg:~] $

Thursday, April 12, 2012

CCIE Voice exam passed!!

Finally....

Still remember back in 2010, my first attempt.  At that time I thought I was good enough to take this challenge, at the end I have spent 3 hours to troubleshoot the phone registration problem and I have got quite a lot of sections with zero marks.

I have put it down for 1.5 years. 2 months ago I have decided to pick it up again and took my 2nd attempt. At that time I was very confidence and I have never thought that I will fail until I see the score report.  That was close.

Finally I made it yesterday.  I can now spend more time on other stuff, instead of pressing the keypad on the phones and make calls days and nights.

3 times more joy than getting my first CCIE R&S which passed in first attempt.  :)