Building explicit tunnels is a painful process, especially when you want to build fully meshed tunnels among a large number of routers. AutoTunnel mesh is a features that mesh LSRs automatically, greatly reduce administrative effort.
- Mesh Group - LSRs to mesh automatically
- Membership identified by
- Matching TE Router ID against ACL
- IGP mesh-group advertisment
- Each member automatically creates tunnel upon detection of a member
- Tunnels instantiated from template
- Individual tunnels not displayed in router configuration
Example Configuration
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup
mpls traffic-eng auto-tunnel mesh
mpls label protocol ldp
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 11.11.11.11 255.255.255.0
!
interface Auto-Template1
ip unnumbered Loopback0
tunnel destination access-list 1
tunnel mode mpls traffic-eng
tunnel bandwidth transmit 0
tunnel bandwidth receive 0
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 dynamic
tunnel mpls traffic-eng fast-reroute node-protect
no routing dynamic
!
interface FastEthernet0/0
ip address 11.1.1.1 255.255.255.0
duplex auto
speed auto
mpls traffic-eng tunnels
mpls label protocol ldp
mpls ip
ip rsvp bandwidth 100000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 51.1.1.1 255.255.255.0
duplex auto
speed auto
mpls traffic-eng tunnels
mpls label protocol ldp
mpls ip
ip rsvp bandwidth 100000
!
interface FastEthernet1/1
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
mpls traffic-eng tunnels
mpls label protocol ldp
mpls ip
ip rsvp bandwidth 100000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 1.1.1.1
log-adjacency-changes
network 11.1.1.1 0.0.0.0 area 0
network 11.11.11.11 0.0.0.0 area 0
network 12.1.1.1 0.0.0.0 area 0
network 51.1.1.1 0.0.0.0 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
access-list 1 permit 11.11.11.11
access-list 1 permit 12.12.12.12
access-list 1 permit 21.21.21.21
access-list 1 permit 22.22.22.22
access-list 1 permit 31.31.31.31
access-list 1 permit 32.32.32.32
access-list 1 permit 41.41.41.41
access-list 1 permit 42.42.42.42
access-list 1 permit 51.51.51.51
access-list 1 permit 52.52.52.52
!
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
end
Output for “show ip int brie” – Tunnels are created automatically
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 11.1.1.1 YES NVRAM up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
FastEthernet1/0 51.1.1.1 YES NVRAM up up
FastEthernet1/1 12.1.1.1 YES NVRAM up up
SSLVPN-VIF0 unassigned NO unset up up
Auto-Template1 11.11.11.11 YES TFTP up up
Loopback0 11.11.11.11 YES NVRAM up up
Tunnel64336 11.11.11.11 YES TFTP up up
Tunnel64337 11.11.11.11 YES TFTP up up
Tunnel64338 11.11.11.11 YES TFTP up up
Tunnel65436 11.11.11.11 YES TFTP up up
Tunnel65437 11.11.11.11 YES TFTP up up
Tunnel65438 11.11.11.11 YES TFTP up up
Output for “show mpls traffic-eng tunnel”
Name: R11_t64336 (Tunnel64336) Destination: 12.12.12.12
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type dynamic (Basis for Setup, path weight 1)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: dynamic path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : FastEthernet0/0, implicit-null
FRR OutLabel : Tunnel65436, explicit-null
RSVP Signalling Info:
Src 11.11.11.11, Dst 12.12.12.12, Tun_Id 64336, Tun_Instance 7510
RSVP Path Info:
My Address: 11.1.1.1
Explicit Route: 11.1.1.2 12.12.12.12
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 12.12.12.12(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 3 days, 8 hours, 9 minutes
Time since path change: 3 days, 8 hours, 9 minutes
Number of LSP IDs (Tun_Instances) used: 82
Current LSP:
Uptime: 3 days, 8 hours, 9 minutes
Name: R11_t64337 (Tunnel64337) Destination: 21.21.21.21
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type dynamic (Basis for Setup, path weight 1)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: dynamic path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : FastEthernet1/1, implicit-null
FRR OutLabel : Tunnel65437, explicit-null
RSVP Signalling Info:
Src 11.11.11.11, Dst 21.21.21.21, Tun_Id 64337, Tun_Instance 6021
RSVP Path Info:
My Address: 12.1.1.1
Explicit Route: 12.1.1.2 21.21.21.21
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 21.21.21.21(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 3 days, 8 hours, 9 minutes
Time since path change: 3 days, 8 hours, 8 minutes
Number of LSP IDs (Tun_Instances) used: 85
Current LSP:
Uptime: 3 days, 8 hours, 8 minutes
Name: R11_t64338 (Tunnel64338) Destination: 22.22.22.22
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type dynamic (Basis for Setup, path weight 2)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: dynamic path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : FastEthernet0/0, 17
FRR OutLabel : Tunnel65438, explicit-null
RSVP Signalling Info:
Src 11.11.11.11, Dst 22.22.22.22, Tun_Id 64338, Tun_Instance 7897
RSVP Path Info:
My Address: 11.1.1.1
Explicit Route: 11.1.1.2 12.2.1.1 12.2.1.2 22.22.22.22
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 12.12.12.12(17) 22.22.22.22(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 3 days, 8 hours, 9 minutes
Time since path change: 3 days, 8 hours, 8 minutes
Number of LSP IDs (Tun_Instances) used: 82
Current LSP:
Uptime: 3 days, 8 hours, 8 minutes
Name: R11_t65436 (Tunnel65436) Destination: 12.12.12.12
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65436 (Basis for Setup, path weight 3)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : FastEthernet1/1, 25
RSVP Signalling Info:
Src 11.11.11.11, Dst 12.12.12.12, Tun_Id 65436, Tun_Instance 13
RSVP Path Info:
My Address: 12.1.1.1
Explicit Route: 12.1.1.2 22.1.1.1 22.1.1.2 12.2.1.2
12.2.1.1 12.12.12.12
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 3 days, 8 hours, 9 minutes
Time since path change: 3 days, 8 hours, 8 minutes
Number of LSP IDs (Tun_Instances) used: 13
Current LSP:
Uptime: 3 days, 8 hours, 8 minutes
Prior LSP:
ID: path option 1 [10]
Removal Trigger: path error
Name: R11_t65437 (Tunnel65437) Destination: 21.21.21.21
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65437 (Basis for Setup, path weight 3)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : FastEthernet0/0, 27
RSVP Signalling Info:
Src 11.11.11.11, Dst 21.21.21.21, Tun_Id 65437, Tun_Instance 6
RSVP Path Info:
My Address: 11.1.1.1
Explicit Route: 11.1.1.2 12.2.1.1 12.2.1.2 22.1.1.2
22.1.1.1 21.21.21.21
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 3 days, 8 hours, 9 minutes
Time since path change: 3 days, 8 hours, 8 minutes
Number of LSP IDs (Tun_Instances) used: 6
Current LSP:
Uptime: 3 days, 8 hours, 8 minutes
Prior LSP:
ID: path option 1 [4]
Removal Trigger: path error
Name: R11_t65438 (Tunnel65438) Destination: 22.22.22.22
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65438 (Basis for Setup, path weight 2)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled
InLabel : -
OutLabel : FastEthernet1/1, 24
RSVP Signalling Info:
Src 11.11.11.11, Dst 22.22.22.22, Tun_Id 65438, Tun_Instance 5
RSVP Path Info:
My Address: 12.1.1.1
Explicit Route: 12.1.1.2 22.1.1.1 22.1.1.2 22.22.22.22
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 3 days, 8 hours, 9 minutes
Time since path change: 3 days, 8 hours, 8 minutes
Number of LSP IDs (Tun_Instances) used: 5
Current LSP:
Uptime: 3 days, 8 hours, 8 minutes
Prior LSP:
ID: path option 1 [2]
Removal Trigger: path error
LSP Tunnel R12_t64336 is signalled, connection is up
InLabel : FastEthernet0/0, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 12.12.12.12, Dst 11.11.11.11, Tun_Id 64336, Tun_Instance 6949
RSVP Path Info:
My Address: 11.11.11.11
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R12_t64338 is signalled, connection is up
InLabel : FastEthernet0/0, 17
OutLabel : FastEthernet1/1, implicit-null
FRR OutLabel : Tunnel65437, explicit-null
RSVP Signalling Info:
Src 12.12.12.12, Dst 21.21.21.21, Tun_Id 64338, Tun_Instance 2040
RSVP Path Info:
My Address: 12.1.1.1
Explicit Route: 12.1.1.2 21.21.21.21
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 21.21.21.21(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R12_t65436 is signalled, connection is up
InLabel : FastEthernet1/1, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 12.12.12.12, Dst 11.11.11.11, Tun_Id 65436, Tun_Instance 12
RSVP Path Info:
My Address: 11.11.11.11
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R12_t65437 is signalled, connection is up
InLabel : FastEthernet0/0, 20
OutLabel : FastEthernet1/1, 29
RSVP Signalling Info:
Src 12.12.12.12, Dst 22.22.22.22, Tun_Id 65437, Tun_Instance 5
RSVP Path Info:
My Address: 12.1.1.1
Explicit Route: 12.1.1.2 22.1.1.1 22.1.1.2 22.22.22.22
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R21_t64337 is signalled, connection is up
InLabel : FastEthernet1/1, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 21.21.21.21, Dst 11.11.11.11, Tun_Id 64337, Tun_Instance 1199
RSVP Path Info:
My Address: 11.11.11.11
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R21_t64338 is signalled, connection is up
InLabel : FastEthernet1/1, 16
OutLabel : FastEthernet0/0, implicit-null
FRR OutLabel : Tunnel65436, explicit-null
RSVP Signalling Info:
Src 21.21.21.21, Dst 12.12.12.12, Tun_Id 64338, Tun_Instance 2599
RSVP Path Info:
My Address: 11.1.1.1
Explicit Route: 11.1.1.2 12.12.12.12
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 12.12.12.12(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R21_t65436 is signalled, connection is up
InLabel : FastEthernet0/0, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 21.21.21.21, Dst 11.11.11.11, Tun_Id 65436, Tun_Instance 6
RSVP Path Info:
My Address: 11.11.11.11
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R21_t65438 is signalled, connection is up
InLabel : FastEthernet1/1, 30
OutLabel : FastEthernet0/0, 30
RSVP Signalling Info:
Src 21.21.21.21, Dst 22.22.22.22, Tun_Id 65438, Tun_Instance 1
RSVP Path Info:
My Address: 11.1.1.1
Explicit Route: 11.1.1.2 12.2.1.1 12.2.1.2 22.22.22.22
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R22_t64336 is signalled, connection is up
InLabel : FastEthernet0/0, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 22.22.22.22, Dst 11.11.11.11, Tun_Id 64336, Tun_Instance 8570
RSVP Path Info:
My Address: 11.11.11.11
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R22_t65436 is signalled, connection is up
InLabel : FastEthernet1/1, 19
OutLabel : FastEthernet0/0, implicit-null
RSVP Signalling Info:
Src 22.22.22.22, Dst 12.12.12.12, Tun_Id 65436, Tun_Instance 7
RSVP Path Info:
My Address: 11.1.1.1
Explicit Route: 11.1.1.2 12.12.12.12
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R22_t65437 is signalled, connection is up
InLabel : FastEthernet1/1, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 22.22.22.22, Dst 11.11.11.11, Tun_Id 65437, Tun_Instance 6
RSVP Path Info:
My Address: 11.11.11.11
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
LSP Tunnel R22_t65438 is signalled, connection is up
InLabel : FastEthernet0/0, 21
OutLabel : FastEthernet1/1, implicit-null
RSVP Signalling Info:
Src 22.22.22.22, Dst 21.21.21.21, Tun_Id 65438, Tun_Instance 4
RSVP Path Info:
My Address: 12.1.1.1
Explicit Route: 12.1.1.2 21.21.21.21
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
No comments:
Post a Comment