Friday, February 3, 2012

RSVP-based Call Admission Control

The previous blogpost discussed about the bandwidth calculation for each of the CAC method:
http://pandaeatsbamboo.blogspot.com/2012/02/call-admission-control-bandwidth.html
In this blogpost we will go a bit more details on how to get it implemented.
RSVP bandwidth calculation is based on the worst case scenario.  For a G.729 call, it is 40Kbps and for G.711, it is 96Kbps.  However it will not based on worst case scenario for every call, it is only used for the first call.  Say for example if I want to implement RSVP-based CAC to 4 x G.729 call, it should be calculated as:
40Kbps + 24Kbps + 24Kbps + 24Kbps = 112Kbps
Okay, then the next step is the router configuration.

1. Create the MTP dspfarm profile with RSVP enabled
sccp local GigabitEthernet0/0
sccp ccm 192.168.20.20 identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 2 register R1-MTP
!
dspfarm profile 2 mtp
codec pass-through
codec g729r8
rsvp
maximum sessions software 10
associate application SCCP

interface Serial0/1/0:0
no ip address
encapsulation frame-relay
fair-queue 64 256 47
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial0/1/0:0.2 point-to-point
bandwidth 768
ip address 192.168.21.1 255.255.255.0
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 202
ip rsvp bandwidth 112

2. Create the MTP entry on UCM, add it to MRG and add the MRG to MRGL.  Assign the MRGL to the device pool / phone.

3. Create Locations, mark the two locations relation as RSVP "Mandatory".

4. Make calls from between the 2 sites, do a "show ip rsvp reservation"

R1#sh ip rsvp reservation
To            From          Pro DPort Sport Next Hop      I/F      Fi Serv BPS
192.168.22.254 192.168.24.254 UDP 18176 16670 none          none     FF LOAD 24K
192.168.24.254 192.168.22.254 UDP 16670 18176 192.168.21.2  Se0/1/0: FF LOAD 24K

Since the ip rsvp bandwidth is 112Kbps, you are allowed to make up to 4 G.729 calls and when you try to make the 5th call, you will see the message "Not Enough Bandwidth" on the phone.

1 comment:

Unknown said...

Dears

i have a problem in configuring IP RSVP

i already configure everything but when i make a call it drop even if i increase the bandwdth to 300 still the call not working

this is my configuration

interface Tunnel0
description MPLS
ip address 172.16.21.122 255.255.255.252
tunnel source GigabitEthernet0/0
tunnel destination 172.18.18.12
!
interface GigabitEthernet0/0
Description "Wan"
ip address dhcp
duplex auto
speed auto
!
interface GigabitEthernet0/1
Description "Lan"
ip address 192.168.63.254 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth 3
!
dspfarm profile 1 mtp
codec pass-through
codec g729r8
rsvp
maximum sessions software 4
associate application SCCP

After that i add the MTP and MRGroup and Assign it to MRList and assign it to the device pool
i configure location and configure that it will talk to other location with rsvp Mandatory
once i do that the call drop but even if i increase the rsv bandwidth in the GiG0/1 to 200 still call will not work

but if i remove the RSVP configuration in the CUCM then the call it work

Please tell me what ami missing



Thansk In Advanced